В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
МАМБЭТ
МАМБЭТ
07.09.2022 22:51 •  Информатика

Нужно написать программу на паскале, которая выводит на экран столбец матрицы , сумма значений элементов которого наименьшая.

Ответ:
anait87
anait87
02.10.2020 12:56
Const
n=10;m=7;
var
a:array[1..n,1..m]of integer;
i,j,min,s,j_m:integer;
     begin     
         for i:=1 to n do         
               begin             
                  writeln;                     
                     for j:=1 to m do                         
                          begin                               
                              a[i,j]:=random(20)-5;                             
                              write(a[i,j]:4);                         
                          end;       
                end;         
writeln;  
{запишем в min чуть больше наибольшего значения суммы, которая может быть в любом столбце. Больше, чем 200 не будет, т.к. всего 10 строк, каждое значение исходя из заполнения матрицы не может быть больше, чем 15 }
min:=200;j_m:=1;
            for j:=1 to m do         
                begin             
                    s:=0;                   
                       for i:=1 to n do                     
                            s:=s+a[i,j];                   
                               if s<min then                     
                                    begin                           
                                       j_m:=j;                         
                                       min:=s;                     
                                    end;             
                              writeln('j :',j,' ',s);  {выводится значение суммы в каждом столбце, необязательно, можно удалить}       
                 end;         
writeln('№ столбца с мин суммой ',j_m);     
     for i:=1 to n do         
            writeln(a[i,j_m]); {вывод нужного столбца}
end.                           
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?