В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
HappyPerson23
HappyPerson23
27.01.2021 07:49 •  Информатика

Составьте программу, по которой на экран будет выведена вся таблица умножения

Ответ:
Chechenec001
Chechenec001
21.07.2020 12:20
Var b,a:integer; 
begin
 for b:=1 to 10 do begin
  for a:=1 to 10 do begin
   writeln(a,'*',b,'=',a*b);
  end;
 end;
end.
получается не в виде таблицы
 а в столбик
0,0(0 оценок)
Ответ:
Кавайныйлебедь
Кавайныйлебедь
21.07.2020 12:20
// F#
[<EntryPoint>]
let main argv =
    let generateTable n m =
        Array2D.init n m (fun i j -> (i+1) * (j+1))
    let printMatrix (matrix:int[,]) =
        printf "    "
        for i = 0 to (Array2D.length1 matrix) - 1 do
            printf "%4d " (i+1)
        printf "\n"
        printf "    "
        for i = 0 to (Array2D.length1 matrix) - 1 do
            printf ""
        printf "\n"
        for j = 0 to (Array2D.length2 matrix) - 1 do
            printf "%2d |" (j+1)
            for i = 0 to (Array2D.length1 matrix) - 1 do
                printf "%4d " matrix.[i, j]
            printf "\n"
        printf "\n"
    let inputArray = generateTable 10 10
    printMatrix inputArray
    System.Console.ReadKey true |> ignore
    0
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?