В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mishkasega77798
mishkasega77798
05.07.2021 07:51 •  Информатика

Составить программу в массиве с n числами поменять местами максимальное и минимальное значения

Ответ:
ыллылыов
ыллылыов
21.07.2020 12:03
Программа может выглядеть так:

uses Crt;
const n=10;
type Mas=array [1..n] of integer;
var A: Mas;
    i, temp, MinInd, MaxInd, Max, Min: integer;
begin
ClrScr;
Randomize;
for i:=1 to  n do
   begin
   A[i]:=10+random(90);
   Write (A[i]:5);
   end;
WriteLn;
Max:=A[1]; MaxInd:=1;
Min:=A[1]; MinInd:=1;
for i:=2 to n do
begin
  if A[i]<Min then
     begin
       Min:=A[i];
       MinInd:=i;
     end
     else
       if A[i]>Max then
       begin
       Max:=A[i];
       MaxInd:=i;
     end;
end;
 temp:=A[MaxInd];
 A[MaxInd]:=A[MinInd];
 A[MinInd]:=temp;
 WriteLn;WriteLn;
 for i:=1 to  n do
   Write (A[i]:5);
 WriteLn;
 ReadLn;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?