Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
рощумникиви
11.04.2022 22:06 •
Информатика
Напишите на paskal введите строку в которой записана сумма натуральных чисел например '1+25+3'
Ответ:
Ника85527
21.07.2020 08:28
Var
i, sum, beg:integer;
str:string;
begin
sum:=0;
beg:=1;
readln(str);
for i:=1 to Length(str) do
if str[i]='+' then
begin
sum:=sum+StrToInt(Copy(str, beg, i-beg));
beg:=i+1;
end;
sum:=sum+StrToInt(Copy(str, beg, Length(str)));
writeln(sum);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
koshuba2017
08.03.2021 19:42
Как перевести десятичный код в двоичный...
valera253
08.03.2021 19:42
F=(a& c)v(b = c) желательно в виде таблицы решить...
gree04
08.03.2021 19:42
Автомобильный номер состоит из нескольких букв, (количество букв одинаковое во всех номерах) за которыми следуют 4 цифры. при этом используется 10 цифр и только 5...
annaelena261280
08.03.2021 19:42
Найти максимальное натуральное число меньше 5000, которое делится нацело на 39....
AbdiashimN
18.11.2022 09:36
Написать программу подсчета количества часов, минут и секунд в данном числе суток. напишите на c++...
Job121
18.11.2022 09:36
Производится двухканальная (стерео) звукозапись с частотой дискретизации 48 кгц и 24 битным разрешением. результаты записываются в файл 3 мб, сжатия данных не происходило....
maulee502owkszf
15.01.2022 14:13
Написать программу, определяющую по координатам трёх точек длины биссектрис треугольника, если таковой существует. (pascalabc)...
DINA2808061
15.01.2022 14:13
Объявить массив из 4 элементов в разделе переменных. организовать ввод значений пользователем. найти среднее значение элементов....
Gloriyaxx
15.01.2022 14:13
Как взаимодействует ос с процессором?...
aarianna
15.01.2022 14:13
Вкаком году была изобретена компьютерная мышь?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
i, sum, beg:integer;
str:string;
begin
sum:=0;
beg:=1;
readln(str);
for i:=1 to Length(str) do
if str[i]='+' then
begin
sum:=sum+StrToInt(Copy(str, beg, i-beg));
beg:=i+1;
end;
sum:=sum+StrToInt(Copy(str, beg, Length(str)));
writeln(sum);
end.