В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
maulee502owkszf
maulee502owkszf
15.01.2022 14:13 •  Информатика

Написать программу, определяющую по координатам трёх точек длины биссектрис треугольника, если таковой существует. (pascalabc)

Ответ:
hard26
hard26
02.10.2020 10:48
Var x:Array[1..3] of integer;// координаты точекy:Array[1..3]of integer;// координаты точекs:Array[1..3]of real; // расстояние между точками b:Array[1..3]of real; // длина бессектрисы   p: real;  beginfor var i:= 1 to 3 dobegin  write('Введите координаты ', i ,' точки');  readln(x[i], y[i]);  end;  writeln('Начало расчетов');  for var i:= 1 to 3 dobegin
if (i < 3) then begin  s[i] := sqrt((x[i]-x[i+1])* (x[i]-x[i+1]) + (y[i]-y[i+1])* (y[i]-y[i+1]));  p := p + s[i];  end  else begin  s[i] := sqrt((x[i]-x[1])* (x[i]-x[1]) + (y[i]-y[1])* (y[i]-y[1]));  p := p + s[i];  end;
  writeln('Расстояние между ', i ,' и ', i+1,' точками    = ', s[i]);  end;    p := p /2;  writeln('полупериметр = ', p);    for var i:= 1 to 3 do  beginif (i = 1) then   b[i] := 2* sqrt(s[1]*s[2]*p * (p - s[3]))/(s[1]+s[2]);if (i = 2) then   b[i] := 2* sqrt(s[2]*s[3]*p *(p - s[1]))/(s[2]+s[3]);if (i = 3) then   b[i] := 2* sqrt(s[3]*s[1]*p *(p - s[2]))/(s[3]+s[1]);   writeln('Длина ', i, ' бессиктрисы ', b[i]); end;end.//определяющую по координатам трёх точек длины биссектрис треугольника,//если таковой существует. (PascalABC)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?