В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
100dan100
100dan100
12.12.2022 19:57 •  Информатика

Напишите программу, после первого четного элемента вставить 0. пример: из массива a[5]: 1 6 8 3 4 должен получиться массив a[6]: 1 6 0 8 3 4.

Ответ:
ника2545
ника2545
21.07.2020 07:28
Const     
n = 10; 
var   
a : array [1..n] of integer; 
r : boolean;   
i,j : integer;
 begin 
//Формирование массива пропущено   
 
r := true;      
While r do   
begin   
 if a[i] mod 2 =0 then     
begin     
 for j := n-1 downto i + 2 do       
 a[j] := a[j-1];       
a[i+1] := 0;       
r := false;     
end;     
i := i +1;   
end;  
for i := 1 to n do 
writeln (a[i]);   
end.

Во избежании ошибок стоит учесть наличие такового элемента в массиве и размерность массива (чтобы его можно было корректно расширить на один элемент)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?