В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
oli21
oli21
08.09.2020 16:03 •  Информатика

Составить программу для вычисления величины s по формуле: s=2(σ^20[i=1]*cos(b^2[i])+e^^10[k=1]*z[k]) program p5_4; var p,s,s1: real; i,k: integer; b: array[1..20] of integer; z: array[1..10] of integer; begin writeln(' z: '); for k: =1 to 10 do begin z[k]: =random(11)-5; write(z[k]: 4); end; writeln; writeln(' b: '); for i: =1 to 20 do begin b[i]: =random(11)-5; write(b[i]: 4); end; p: =1; s1: =0; for i: =1 to 20 do s1: =2*(s1+cos(sqr(; for k: =1 to 10 do p: =p*(z[k]); s: =s1+p; writeln(' s=',s: 2: 5); end. нам преподаватель сказал сделать без команды random, а я не пойму как она здесь будет выглядеть без random, так же и другая

Ответ:
Shizuka494
Shizuka494
31.07.2020 07:29
Без рандома:

program p5_4;
var
P,S,S1:real; i,k:integer;
b:array[1..20] of integer;
z:array[1..10] of integer;
begin
writeln(' z: ');
for k:=1 to 10 do
begin
Readln(z[k]);
write(z[k]:4);
end;
writeln;
writeln(' b: ');
for i:=1 to 20 do
begin
Readln(b[i]);
write(b[i]:4);
end;
P:=1;
S1:=0;
for i:=1 to 20 do
S1:=2*(S1+cos(sqr(b[i])));
for k:=1 to 10 do
P:=P*(z[k]);
S:=S1+P;
writeln(' S=',S:2:5);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?