В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Moon133
Moon133
16.12.2022 08:00 •  Информатика

Написать программу! найти сумму чётных чисел в интервале от а до в ( а и в - натуральные числа, а< в).

Ответ:
mmsh19
mmsh19
02.10.2020 11:50
uses Crt;
 var a, b, temp, i, S:integer;
 begin
 ClrScr;

 Write (' a = ');   ReadLn(a);
 Write (' b = ');   ReadLn(b);
 S:=0;
 i:=a;
 while i<=b do
   begin
     if (i mod 2 = 0) then S:=S+i;
     i:=i+1;
   end;
 WriteLn(' S = ', S);
 ReadLn;
 end.
0,0(0 оценок)
Ответ:
tupoeMango
tupoeMango
02.10.2020 11:50
Var a,b,i,sum: integer; 
begin 

write ('Введите границы интервала: ');

read (a,b); 

for i:= a to b do 

if i mod 2 = 0 then sum:=sum + i;

writeln ('Сумма четных чисел в интервале от А до Б = ',sum);

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?