В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
MilaPlay123
MilaPlay123
17.04.2020 15:38 •  Информатика

Составить программу для c++ "ввести возраст человека и вывести его вместе со словом год,года,лет(пример вам 1 год,вам 2 года,вам 55 лет)

Ответ:
Anna050503
Anna050503
03.10.2020 09:58
#include <iostream>
int main()
{
    using namespace std;
    system("chcp 1251 > nul"); //для кириллицы
    int age;
    cout << "Введите возраст: ";
    cin >> age;
    if (age > 4 && age < 21)
         cout << age << " ЛЕТ" << endl;
    else if (age % 10 == 1)
        cout << age << " ГОД" << endl;
    else if (age % 10 > 1 && age % 10 < 5)
        cout << age << " ГОДА" << endl;
    else
        cout << age << " ЛЕТ" << endl;
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?