В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Vftfg
Vftfg
01.08.2021 07:50 •  Информатика

Написать программу поиска любого элемента в массиве. для уточнения - на языке программирования, для программы паскаль.

Ответ:
marinapizdec
marinapizdec
02.10.2020 11:38
Program pm;
uses crt;
var X:array[1..1000] of integer; k,a,b,i:integer;
begin
clrscr;
write('Введите кол-во элементов массива: ');
read(k);
writeln;
write('Введите диапазон значений заполнения(A-начальное значение, B-конечное): ');
repeat
read(a,b);
until a<=b;
writeln;
randomize;
for i:=1 to k do X[i]:=random(b-a+1)+a;
writeln('Ваш массив:');
for i:=1 to k do write(X[i]:5);
writeln;
write('Введите элемент поиска: ');
read(b);
a:=0;
for i:=1 to k do if X[i]=b then a:=i;
if a>0 then writeln('Элемент со значением ',b,' имеет индекс ',a)
else writeln('Элемента не существует!');
readkey;
end.
0,0(0 оценок)
Ответ:
Svetbor04
Svetbor04
02.10.2020 11:38
Поиска индекса элемента по заданному значению или поиска значения по заданному индексу? Напишу решение для обоих случаев.
1.
Поиск элемента по заданному индексу
var
n:longint;
m:array[1..1000] of longint;
begin
writeln('Введите индекс элемента массива');
read(n);
writeln('Элемент под номером ',n,' равен ',m[n]);
end.

2. Поиск индекса по заданному значению в неупорядоченном массиве:
var
n,i:longint;
m:array[1..1000] of longint;
begin
read(n);
i:=1;
while m[i]<>n do
i:=i+1;
writeln(m[i]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?