В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
qqwqe
qqwqe
10.10.2021 22:43 •  Информатика

Напишите программу на Паскале с операторами mod и div. Дано трехзначное число. Определить кратна ли сумма его цифр числу а.​

Ответ:
сонЯ20101
сонЯ20101
05.12.2020 23:43

program amountnumbers;

var

 amount, number, a: integer;

begin

 write('Введите трехзначное число: ');

 read(number);

 writeln('Введите число А:');

 read(a);

 while number > 0 do

 begin

   amount := amount + number mod 10;

   number := number div 10;

 end;

 if (amount mod a = 0) then

   writeln('Да')

 else

   writeln('Нет');

end.

Объяснение:

program amountnumbers;  // Название программы

var

 amount, number, a: integer;  // Целочисленные переменные:

amount - сумма цифр трехзначного числа;number - трехзначное число, вводимое с клавиатуры;a - число для проверки на кратность.

begin  // Начало программы

 write('Введите трехзначное число: ');  // Вывод сообщения в консоль

 read(number);  // Считываем трехзначное число с клавиатуры

 writeln('Введите число А:');  // Вывод сообщения в консоль

 read(a);  // Считываем число А с клавиатуры

 while number > 0 do  // Пока значение переменной number > 0

 begin  // Начало цикла

   amount := amount + number mod 10;  // Сумма цифр = сумма цифр + последняя цифра числа

   number := number div 10;  // Отделяем последнюю цифру от числа

 end;  // Конец  цикла

 if (amount mod a = 0) then  // Если значение переменной amount делится на значение переменной A без остатка, тогда

   writeln('Да')  // Вывод сообщения в консоль

 else  // Иначе

   writeln('Нет');  // Вывод сообщения в консоль

end. // Конец программы

0,0(0 оценок)
Ответ:
lenasavostyanova
lenasavostyanova
05.12.2020 23:43

program z1;

var n,a:integer;

begin

write('n = ');

readln(n);

write('a = ');

readln(a);

if (n mod 10 + n div 100 + n div 10 mod 10) mod a = 0 then write ('Сумма цифр числа ',n,' кратна числу ',a)

else write ('Сумма цифр числа ',n,' не кратна числу ',a)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?