В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
galina157
galina157
09.10.2022 18:25 •  Информатика

Составьте программу подсчитывающу количество положительных и отрицательных оценок полученных за контрольную работу в классе 29 человек. положительным оценка щитаются 3,4,5 отрицательные 2

Ответ:
ogurhik
ogurhik
20.07.2020 18:59
эммм..

C++

#include <iostream>
using namespace std;

int maiin(){

 int ocenka = 0, count = 0, pol = 0, otr = 0;

  while(count<=29){
    cout<<"Введите оценку :";
    cin>>ocenka;//получили оценку
    if (ocenka>=3){pol++;} else {otr--;}
    count++;
   
  }
cout<<"Положительных - "<<pol<<" ; Отрицательных - "<<otr<<endl;
 return 0;
}
0,0(0 оценок)
Ответ:
7kotik7myr7myr7
7kotik7myr7myr7
20.07.2020 18:59
Pascal

Const n=29;
Var g,b,i,a:integer;

BEGIN
for i:=1 to n do begin
writeln('Введите оценку');
read(a);
if a<=2 then b:=b+1{считаем количество отрицательных оценок} else g:=g+1;{считаем положительные}
end;
write('отрицательных: ',b , 'положителных: ' g);
END.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?