В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Стонт2132
Стонт2132
12.02.2020 13:19 •  Информатика

Написать программы в паскале авс. 1) написать программу вычисления средней линии трапеции. 2) ввести 2 числа.найти меньшее и вывести на экран. 3) вывести на экран 15 член арифметической прогрессии ,если заданы а1 и разность d. 4) записать программу нахождения периметра 8- миугольника,если каждая сторона,начиная со второй больше первой на 2 см вас,)

Ответ:
ДанилЮсупов
ДанилЮсупов
20.07.2020 15:08
1)
var a, b, l: real;
begin
write('Введите a, b>> ');
read(a, b);
l:=(a+b)/2;
writeln(l);
end.

2)
var a, b: integer;
begin
write('Введите 2 числа>> ');
read(a, b);
if a<b then writeln(a) else writeln(b);
end.

3)
var a1, d, n, sr: real;
begin
write('Введите a1, d>> ');
read(a1, d);
n:=15;
sr:=a1+d*(n-1);
writeln(sr);
end.

4)
var
a, d, p: real;
i: byte;
begin
write('Введите первую сторону>> ');
read(a);
for i:=1 to 8 do
begin
p:=p+a;
a:=a+2;
end;
writeln('P = ', p);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?