В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Anna260
Anna260
03.05.2021 19:49 •  Информатика

Решите на паскале недавно школьник петя придумал классную идею для своего стартапа. идея состоит в том, чтобы написать программу, которая определяет эмоциональный оттенок сообщений пользователей из всем известной социальной сети. петя считает, что думать над качественным решением нет смысла — ведь приложение нужно как можно скорее выбросить на рынок, пока этого не сделали конкуренты. поэтому в первой версии петя собирается использовать следующий алгоритм: • сначала в сообщении нужно посчитать количество символов «)», «(», «! » и «.». • если в сообщении больше всего символов «)» — значит автору сообщения весело, и программа должна вывести «funny». • если в сообщении больше всего символов «(» — значит автору сообщения грустно, и програм- ма должна вывести «sad». • если в сообщении больше всего символов «! » — значит автор сообщения раздражен, и про- грамма должна вывести «angry». • если в сообщении больше всего символов «.» — значит перед нами какое-то глубокомысленное сообщение с большим числом многоточий, и программа должна вывести «deep». • если каких-либо наиболее число встречающихся символов (из перечисленных выше) поровну — то тогда эмоция сообщения не понятна и программа должны вывести «unclear».

Ответ:
Dastannn1
Dastannn1
04.10.2020 12:39
program
var
s: string;
a:array[1..4] of integer;
i:integer;
begin
 read(s);
 for i:=1 to 4 do a[i]:=0;
 
 for i:=0 to length(s) do
 begin
    if s[i]=')' then inc(a[1]);
    if s[i]='(' then inc(a[2]);
    if s[i]='!' then inc(a[3]);
    if s[i]='.' then inc(a[4]);
 end;
 
 if(a[1]>a[2])and(a[1]>a[3])and(a[1]>a[4]) then write('Funny')else
 if(a[2]>a[1])and(a[2]>a[3])and(a[2]>a[4]) then write('Sad') else
 if(a[3]>a[2])and(a[3]>a[1])and(a[3]>a[4]) then write('Angry') else
 if(a[4]>a[2])and(a[4]>a[3])and(a[4]>a[1]) then write('Deep') else
    write('Unclear');

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?