В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
AdamM2
AdamM2
01.01.2022 07:45 •  Информатика

Нужна . pascalabc №1 составить программу, которая выводит на экран дни с нулевой температурой. составить программу, которая выводит на экран дни с минимальной и максимальной температурой. составить программу, которая выводит на экран дни с одинаковой температурой. №2 "ввод и обработка прямоугольных массивов" создайте проект ж/д расписание. проверьте его на работо дополните программу следующими функциями: - нахождения номера поезда, который прибывает первым на станцию после 18.00. - сколько через станцию проходит поездов с номерами в пределах от 50 до 150. - сколько поездов прибывает на станцию в первую половину суток; - укажите номера поездов, которые прибывают на 1 платформу. контролер прибыл на станцию с поездом №, на какую платформу ему нужно перейти, чтобы отправиться далее, не потеряв времени. заранее

Ответ:
EkaterinaVNTOGLIATTI
EkaterinaVNTOGLIATTI
02.10.2020 10:52
Пусть данные о температуре хранятся в массиве Тemp  и количество данных (для определенности равно числу дней в месяце n=30)
program Temperatura;
const n=30;
type Mas = array [1..n] of integer;
var A: Mas;
     i,  Max, MaxInd, Min, MinInd: integer;

begin
for i:=1 to n do
   A[i]:=-20+random(40);          {Заполняем массив случайными числами}
{

А  СЮДА  ВСТАВЛЯЕМ ПО ОЧЕРЕДИ БЛОКИ

}

ReadLn;
end.

{БЛОК:: Дни с нулевой}
for i:=1 to n do
   if A[i] =0 tnen WriteLn(' Day Number ' ,i
);

{БЛОК:  Дни с MaxTemp и MinTemp}
Max:=A[1];
Min:=A[1];
MaxInd:=1;
MinInd:=1;
for i:=2 to n do
   begin
     if A[i]>Max then begin
                                 Max:=A[i];  MaxInd:=i
                               end;
     if A[i]<Min then begin
                               Min:=A[i];  MinInd:=i;
                             end;
   end;
   WriteLn('Max=', Max, '  MaxInd=' , MaxInd);
   WriteLn('Min=', Min, '  MinInd=' , MinInd);
ReadLn;
end.

{Ну а последний БЛОК (о днях с одинаковой температурой) попробуй написать САМ}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?