В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
greentyler451
greentyler451
15.05.2021 18:56 •  Информатика

Pascal напишите программу, которая в последовательности натуральных чисел находит количество отрицательных чисел, кратных 10. программа получает на вход натуральные числа, количество введенных числе неизвестно, последовательность чисел заканчивается числом -100 (минус 100). решить циклом while.

Ответ:
ban20050408
ban20050408
19.07.2020 22:16
Var
  n,k:integer;
  loop:boolean;
begin
  Writeln('Введите целые числа, окончание ввода по числу -100');
  k:=0;
  loop:=true;
  while loop do
  begin
    Read(n);
    loop:=(n<>-100);
    if loop then
      if (n<0) and ((n mod 10)=0) then Inc(k)
  end;
  Writeln('Количество отрицательных чисел, кратных 10, равно ',k)
end.

Тестовое решение:
Введите целые числа, окончание ввода по числу -100
40 52 -23 16 1000 -240 35 6 0 -20 7 -100
Количество отрицательных чисел, кратных 10, равно 2
0,0(0 оценок)
Ответ:
Анндрейй
Анндрейй
19.07.2020 22:16
var
  x, s : integer;
  t: boolean;
begin
  s := 0;
  while  t=false do
    begin
      writeln(i,' число:');
      readln(x);
      if x = -100 then t:=true;
      if (x < 0) and (x mod 10 = 0)) then s:=s+1;
    end;
    writeln('ответ ',s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?