В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
catnoir227
catnoir227
10.08.2020 03:12 •  Информатика

Поскорее можно? напишите программу,которая находит среднее из трех введенных числе. предполагается что все три числа различные

Ответ:
Tiger333
Tiger333
19.07.2020 19:53
Я думаю, что имеется в виду среднее по значению
Pascal : 
var arr : array[0..2] of integer; { если числа целые }
     i, j, t : integer;
begin
  read(arr[0], arr[1], arr[2]); 
  // самый простой это отсортировать массив
  // в данном случае можно использовать сортировку "пузырьком"
  for i := 0 to 2 do 
    for j := 0 to 2 do 
      if arr[ j ] > arr[ j + 1]
        begin
          t := arr[ j ];
          arr[ j ] := arr[ j + 1];
          arr[ j + 1 ] := t;
        end;
 //Конечно, среднее по значению число будет храниться в элементе arr[1]
  writeln(arr[1]);
end.
На случай, если в учебнике просят среднее арифметическое, понятно, что нужно просто вывести ( arr[0] + arr[1] + arr[2] ) / 3
Если есть какие-то вопросы, то можете написать личное сообщение
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?