В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
angelina2005hs
angelina2005hs
12.02.2021 00:27 •  Информатика

Дан целочисленный массив из 31 элемента, элементы массива могут принимать значения от -20 до 20. написать программу, которая выводит среднюю температуру среди дней, когда была оттепель.

Ответ:
soom2
soom2
02.10.2020 09:52
Var a,b,i:integer;
n:real;
mass:array[1..31] of integer;
begin
for i:=1 to 31 do begin
mass[i]:=random(40)-20;
if mass[i]>0 then begin
b:=b+1;
a:=a+mass[i];
end;
end;
writeln('Полученные значения');
for i:=1 to 31 do
write(mass[i]:4);
n:=a/b;
writeln;
writeln('Средняя температура равна ',n:3:1);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?