В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Danil02020202
Danil02020202
22.07.2022 02:02 •  Информатика

Нужна : составить программу по которой компьютер угадает число введеное с клавиатуры (с repeat), с пояснениями (игра похожа на игру угадай число, но угадывает компьютер, а мы задумываем)

Ответ:
Санчоус146854
Санчоус146854
25.05.2020 23:17

var x,y,a:integer;
c:boolean;
begin
readln(x); {считываем}

a:=1;
repeat

writeln(a,' попытка выбор компьютера пал на - ');
y:=random(x)+1; {задаем промежуток рандомом}

write(y);
if x=y {сравниваем} then c:=true; {выходим из цикла в случае успеха}
until c; {если с=true тогда выход из цикла, иначе крутимся дальше}

writeln('Компьютер сделал ',a,' попыток.');
end.


Более доработанная и понятная, если возникают какие-то вопросы - пиши в личку.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?