В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
KotesUA
KotesUA
03.05.2021 07:21 •  Информатика

Написать программу в паскале по вычислению средний температуры за неделю.исходные данные вводятся с клавиатуры: понедельник 12 градусов вторник 10 среда 16 четверг 18 пятница 17 суббота 16 воскресенье 14

Ответ:
liz93
liz93
25.05.2020 22:41

var

  t: array [1..7] of real;  //Массив температуры за неделю

  s: real;

  i: integer;

 

begin

  s:= 0;

  for i:= 1 to 7 do  //Вводим температуру за каждый день

  begin

    writeln('Введите температура в ', i, ' день недели');

    readln(t[i]);

    s:= s + t[i];

  end;

  writeln('Средняя температуры за неделю:  ', s / 7 : 0 : 5);  {Выводим среднюю температуру за неделю с округлением до 5 знаков после запятой}

end.

  

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?