В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Paris99
Paris99
19.01.2022 18:42 •  Информатика

Пользователь вводит с клавиатуры число N. Программа выводит на экран три числа:
1) сумму всех чисел на промежутке от 1 до N;
2) произведение всех нечетных чисел на промежутке от 1 до N.
3) количество чисел, которые делятся нацело на 3 на промежутке от 1 до N.
Входные данные:
Одно целое число N.
Исходные данные:
Вывести три числа: 1) сумму всех чисел;
2) произведение нечетных чисел;
3) количество чисел, которые делятся на 3

Ответ:
ilyazavrik
ilyazavrik
19.01.2021 18:25

N = int(input())

sums = 0

pr = 1

counter = 0

for i in range(1,N+1):

   sums += i

for i in range(1,N+1,2):

   pr *= i

for i in range(1,N+1):

   if i % 3 == 0:

       counter += 1

print(sums)

print(pr)

print(counter)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?