В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
snsn
snsn
18.04.2022 19:42 •  Информатика

Решить в паскале с использованием цикла с ! составить программу запроса пароля пока не будет введён пароль верно. в программе предусмотреть счётчик неправильных вводов пароля.

Ответ:
ДаняБл
ДаняБл
25.05.2020 21:57

var

 parole, s: string;

 Count: byte;

begin

 parole := 'Земля прощай. В добрый путь!';

 Count := 0;

 

 repeat

   Writeln('Введите пароль');

   Readln(s);

   Count += 1

 until (s = parole) or (Count = 3);

 

 if Count = 3 then

 begin

   Write('Вы не индентификацию. Доступ закрыт');

   Halt

 end

 else

   Write('Доступ разрешен.')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?