Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Sasha280405
13.04.2020 19:00 •
Информатика
Составить программу для сортировки методом сплошного просмотра по убыванию произвольного массива g(n). отсортировать массив а(10) методом пузырька по возрастанию. =***
Ответ:
zveriok
02.10.2020 05:33
Исходный код на С++:
#include <iostream>
using namespace std;
int main()
{
int size;
cin >> size;
int *a = new int[size];
for (int i = 0; i < size; i++)
{
cin >> a[i];
}
for (int i = 0; i < size; i++)
{
for (int j = size - 1; j > i; j--)
{
if (a[j] < a[j - 1])
{
swap (a[j], a[j - 1]);
}
}
}
for (int i = 0; i < size; i++)
{
cout << a[i] << ' ';
}
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
JessyMurMur
04.02.2020 18:36
Датчик ультразвука саОпредели назначение датчика ультразвука.—определение расстояния до препятствия, расположенного перед роботомиеопределение цвета предметаопределение...
pikulev
20.01.2023 05:27
Сколько нулей в двоичной записи десятичного числа ++3?...
Андре127
13.08.2020 02:06
Дано натуральное число m. составить программу, которая разбивает это число на три приблизительно равных натуральных числа....
Svetlanaaaa16
01.05.2021 16:41
Слева представлены возможности человека справа дополнить устройствами компьютера похожими на возможности человека...
LeНин
01.05.2021 16:41
Допишите рассказ: «мне купили компьютер! и первым делом я…»...
gerasiko
01.05.2021 16:41
Рассеянный ученик прикрепил жевательную резинку к розетки какие правила безопасности он нарушил?...
57Nika57
26.06.2022 10:22
Составит программу, которая для символа = выводит предыдущий и следующий символы. в паскале....
vladduliman5
26.06.2022 10:22
Написать небольшое сочинение : от каждого зависит все...
заря24
26.06.2022 10:22
Специалистов каких профессий подготавливали в средневековых университетах?...
Вика7473
26.06.2022 10:22
Образуйте степени сравнения следующих прилагательных и наречий: many, comfortable, wide,early,hospitable, little, rich, light....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <iostream>
using namespace std;
int main()
{
int size;
cin >> size;
int *a = new int[size];
for (int i = 0; i < size; i++)
{
cin >> a[i];
}
for (int i = 0; i < size; i++)
{
for (int j = size - 1; j > i; j--)
{
if (a[j] < a[j - 1])
{
swap (a[j], a[j - 1]);
}
}
}
for (int i = 0; i < size; i++)
{
cout << a[i] << ' ';
}
return 0;
}