В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
YAMAYKA123
YAMAYKA123
10.02.2021 02:14 •  Информатика

Написать программу. угадай число. один из партнеров вводит в программу число, а второй должен отгадать это число. причем на каждый предложенный вариант программа отвечает либо «больше», либо «меньше» до тех пор, пока число не будет отгадано. вывести количество попыток, которое было сделано.

Ответ:
Георгий20004
Георгий20004
15.07.2020 20:58
Var a,i,b:integer;
begin
  writeln('Введи число');
  readln(a);
  writeln('Уадай');
  while a<>b do
  begin
  readln(b);
  if a<b then 
  begin writeln('Меньше'); i:=i+1; end
  else
  if a>b then
  begin writeln('Больше'); i:=i+1; end;
  end;
  writeln('Попыток было:', i)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?