В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
xXEliteXx
xXEliteXx
26.07.2020 03:06 •  Информатика

Напишите программу. группа студентов сдает экзамен. оценки формируются случайным образом от 2 до 5. напечатать кол-во полученых двок,трок,четверок,пятерок

Ответ:
Эргаш2Исамов
Эргаш2Исамов
02.10.2020 05:27
Pascal

const  n = 10; //Кол-во студентов
//можно сделать с вводом с клавиатуры
    var  i,a : integer; 
 o : array[2..5] of integer; 
     begin 
randomize; 
 for i :=2 to  5 do 
  o[i] := 0;   
 
for i := 1 to N do 
 begin 
   a := 2 + random(4); 
   o[a] := o[a] +1; 
  end; 
 for i := 2 to 5 do 
  writeln (i,'=',o[i]); 
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?