В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
SergeSaenko
SergeSaenko
19.06.2021 20:17 •  Информатика

Дан массив из n целых чисел.написать программу,определяющую,максимальный элемент массива и его номер.

Ответ:
biobiobio
biobiobio
02.10.2020 05:12
C++:

#Include <iostream>

using namespace std;

int main()
{
   int N;
   cin >> N;
   int a;
   cin >> a;
   int max = a;
   for(int i = 1; i < N; i++)
   {
     cin >> a; 
     if(a > max) max = a;
   }
   cout << max << endl;
   return 0;
}

//Тут технически без массива(он не хранится в памяти программы), на самом деле он тут не особо нужен.
0,0(0 оценок)
Ответ:
daniilnv2
daniilnv2
02.10.2020 05:12
Pascal:
a: array [1..10000] of integer;
i, n, m: integer;
begin
readln(n);
for i := 1 to  n do
  read(a[i]);
m := 1;
for i := 2 to n do
if (a[i] > a[m])
then m := i;
writeln(a[m],' ',m);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?