В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составьте программу, определяющую максимальный элемент и его индексы матрицы а размерами mxn(паскаль)

Ответ:
Pro100darik
Pro100darik
02.10.2020 04:20
Смотри на скриншот я сделал просто не хочу чтоб форматировка текста портилась.Все работает!
const n=3;m=4;
var a:array [1..n,1..m] of integer;    i,j,k,max:Integer;    ind:array [0..1] of Integer=(1,1);
begin 
Randomize; 
 for i:=Low(a) to High(a) do 
 for j:=Low(a) to High(a[1]) do 
   a[i,j]:=Random(100); 
for i:=Low(a) to High(a) do 
  begin   
  writeln;   
for j:=Low(a) to High(a[1]) do 
 write(a[i,j]:3); 
 end; 
 max:=a[1,1]; 
 for i:=Low(a) to High(a) do   
for j:=Low(a) to High(a[1]) do
    if a[i,j]> max then   
  begin 
     max:=a[i,j];   
    ind[0]:=i;     
  ind[1]:=j;     
end;     
writeln; 
Writeln(' Max element: ',max);
 Write(' Index: '); 
 for i:=0 to 1 do 
 write(ind[i],' ');
 Readln;
end. 
Составьте программу, определяющую максимальный элемент и его индексы матрицы а размерами mxn(паскаль
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?