В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
pisyun228lolkek
pisyun228lolkek
09.11.2020 01:26 •  Информатика

Составьте программу,которая заполняет массив a[1..10] случайными числами в диапазоне от 0 до 10,затем первый элемент меняет местами с максимальным элементом.выведите на экран исходный и полученный массивы.

Ответ:
mlyz
mlyz
14.07.2020 17:47
Program asd;
var 
a,b,c,i:integer;
ar:array[1..11] of integer;
begin
for i:=1 to 10 do begin
a:=random(10);
ar[i]:=a;
end;
for i:=1 to 10 do write(ar[i],' ');
b:=ar[1];
for i := 2 to 10 do
if ar[i] > b then begin b:=ar[i];
c:=i;
end;
ar[c]:=ar[1]; 
ar[1]:=b;
writeln();
 for i:=1 to 10 do write(ar[i],' ');
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?