В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Игнат282
Игнат282
11.07.2020 19:06 •  Информатика

A) составьте программу, которая заполняет масcив a[10..20] случайными целыми числами в диапазоне от 10 до 20, затем меняет местами первый и последний элементы. выведите на экран исходный и полученный массивы. б) составьте программу, которая заполняет масcив a[10..20] случайными целыми числами в диапазоне от 1 до 100, затем меняет местами максимальный и минимальный элементы. выведите на экран исходный и полученный массивы. программы должны выводиться в строчку.(write)

Ответ:
snejanaterg
snejanaterg
02.10.2020 03:52
Var
i,x:integer;
m:array[10..20] of integer;
begin
randomize;
for i:=10 to 20 do m[i]:=random(11)+10;
for i:=10 to 20 do write(m[i],' ');
writeln;
x:=m[10];
m[10]:=m[20];
m[20]:=x;
for i:=10 to 20 do write(m[i],' ');
writeln;
end.

2)

var
max,min,i,x:integer;
m:array[10..20] of integer;
begin
min:=10;
max:=10;
randomize;
for i:=10 to 20 do m[i]:=random(100)+1;
for i:=10 to 20 do write(m[i],' ');
writeln;
for i:=10 to 20 do begin if m[i]<m[min] then min:=i;
if m[i]>m[max] then max:=i;
end;
x:=m[min];
m[min]:=m[max];
m[max]:=x;
for i:=10 to 20 do write(m[i],' ');
writeln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?