В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Starbiliya2003
Starbiliya2003
18.04.2020 03:07 •  Информатика

Написать программу, которая для первых n натуральных чисел находит сумму чётных и произведение нечётных чисел. число n вводится с клавиатуры . выполнить программу для n=13 , записать результат

Ответ:
KristinkaOvchin
KristinkaOvchin
13.07.2020 23:40
Const n=13;
var i,s,p:integer;
begin
s:=0; p:=1;
for i:=1 to n do begin
if (i mod 2 = 0) then s:=s+i;
if (i mod 2 <> 0) then p:=p*i;
end;
writeln("Сумма четных = ",s," , произведение нечетных =",p);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?