Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
llamina
23.07.2021 15:32 •
Информатика
Составить программу, которая генерирует 10 случайных чисел в диапазоне от -20 до 30,выводит эти числа на экран и вычисляет сумму отрицательных
Ответ:
ilyagnomm
13.07.2020 22:29
Var a:array[1..10] of integer;
i,s:integer;
begin
randomize;
for i:=1 to 10 do begin
a[i]:=random(51)-20; write(a[i],' '); end;
writeln;
s:=0;
for i:=1 to 10 do
if a[i]<0 then s:= s+a[i];
writeln('Сумма отрицательных чисел равна ', s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
крузейро
19.06.2021 10:58
Какой алфавит наешл наибольшее распространиние в различных сферах деятеьности? как называетються символы этого алфавита...
varksen
19.06.2021 10:58
Как египтяне перешли от изображения значков целого слова к изображению значком отдельного звука...
Crownglas
08.03.2020 17:00
40 ! решите уравнение x^2=5cos(x-1) методом перебора и методом деления отрезка пополам, а также с табличного процессора. сравните количество шагов цикла при использовании...
90125
23.08.2021 17:21
Сделать в тетраде/на телефоне ...
Aslan006
17.01.2023 12:11
3.Какие значения и навыки необходимы для программиста?...
asdfghjkl6tygb
17.01.2023 12:11
Как в Python отмечаются целые числя? Как в Python отмечаются дробные (вещественные) числа очень ...
дРуЗьЯ007
19.12.2020 20:50
Написать программу на pascal, которая позволяет ввести с клавиатуры 9 элементов массива целого типа и выводит их на экран в столбик...
bolatzarina
19.12.2020 20:50
Скорость информационного потока - 20 бит/сек.сколько времени потребуется для передачи информации объемом в 10 байт...
mumu9
21.01.2022 08:27
Автор произведения 《старый гриб》...
mischkulentsov
29.09.2022 02:11
СОСТАВЬТЕ СЛОВО ИЗ БУКВ: О Е О А Е С Л О К Н П Р Д Ь Это насекомое...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
i,s:integer;
begin
randomize;
for i:=1 to 10 do begin
a[i]:=random(51)-20; write(a[i],' '); end;
writeln;
s:=0;
for i:=1 to 10 do
if a[i]<0 then s:= s+a[i];
writeln('Сумма отрицательных чисел равна ', s);
end.