В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Abdresh
Abdresh
30.11.2020 15:55 •  Информатика

Составить программу! : )в массиве из 10 целых чисел заменить все отрицательные элементы на минимальный элемент, а все положительные – на максимальный.

Ответ:
мангл63
мангл63
13.07.2020 16:51
На паскаль: 
var
a: array [1..10] of integer;

max, min, i: integer;

begin

for i := 1 to 10 do
read(a[i]);

 max:=-maxint;
 min:= maxint;
for i:= 1 to 10 do 
if  (a[i]>max) then max:=a[i];
for i := 1 to 10 do
if (a[i]<min) then min := a[i];
for i := 1 to 10 do
if (a[i]<0) then a[i] := min else if (a[i]>0) then a[i]:=max;
for i := 1 to 10 do
write(a[i],' ');
readln;
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?