В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Nastya14231
Nastya14231
01.02.2020 05:34 •  Информатика

1)в free pascal составить программу нахождения суммы цифр четырехзначного числа 2) составить программу: если существует треугольник,со сторонами a,b,c , то напечатать "да",а иначе напечатать "нет"

Ответ:
katushashamrova
katushashamrova
25.05.2020 16:40

var sum, k, i: integer;


begin
readln (k);
while k > 0 do
begin
sum := sum + k mod 10; //прибавляем к сумме последнюю цифру в числе k
k := k div 10; //убираем из k эту последнюю цифру
end;
writeln(sum);
end.

 

 

 

 

 

 

var a, b, c: integer;


begin
  readln (a);
  readln (b);
  readln (c);
  if (((a + b) > c) and ((a + c) > b) and ((c + b) > a)) then //у треугольника сумма двух сторон больше третьей стороны
    writeln('да')
  else writeln ('нет');
end.

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?