Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
katrinzeta18
24.01.2023 09:19 •
Информатика
Написать программу которая из двух строк составляет третью, путём чередования символов первой и второй строки.
Ответ:
olyaokeio
12.07.2020 14:38
program tref;
var a1,a2,a3:string;i,c,b,j,a:integer;
begin
a:=1;
b:=1;
readln(a1);
readln(a2);
a3:=a1+a2;for i:=1 to length(a1)*2 do
begin
if(i mod 2 = 1)then
begin
a3[i]:=a1[b];
b:=b+1; end;;
if(i mod 2 = 0)then
begin
a3[i]:=a2[a];
a:=a+1;
end;
end;
writeln(a3);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
алишер126
09.02.2022 20:38
Слова связынные с компьютером 4 буква т...
лим0н
09.02.2022 20:38
Написать программу в паскале, используя repeat until . : дана непустая последовательность, оканчивающаяся нулем. найти в ней минимальную цифру....
Азяка21
09.02.2022 20:38
Вклассе 111100(двоичная система)%девочек и 1100(двоичная) мальчиков. сколько учеников в классе?...
botanchik1
27.02.2020 04:18
Закодировать текст в коде кои-! текст: суан-пан , ibm ! десятичный код? двоичный код?...
Nastyushon
29.12.2022 15:24
Поставить буквы обратно алфавиту а цифры в порядке убывания 6к9ар71цес5уми...
Jama133
29.12.2022 15:24
Кодирование текста осуществляется перестановкой букв в каждом слове по одному и тому же правилу. восстановите кодированую информацию и сформулируйте правила перестановки....
Lana111111111111
29.12.2022 15:24
Информатика 4 класс часть 2 стр 42 рудченко...
anatoliy92itf
27.02.2022 07:42
Чему в десятичной системе счисления равно число 1110012?...
dree123
24.06.2021 10:41
Что это делает? if word == word[: : -1]...
karevmaxim4974owjcrc
09.03.2022 06:55
Пользователь работал с каталогом девочки. сначала он поднялся на один уровень вверх, затем спустился на один уровень вниз, потом ещё раз спустился на...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a1,a2,a3:string;i,c,b,j,a:integer;
begin
a:=1;
b:=1;
readln(a1);
readln(a2);
a3:=a1+a2;for i:=1 to length(a1)*2 do
begin
if(i mod 2 = 1)then
begin
a3[i]:=a1[b];
b:=b+1; end;;
if(i mod 2 = 0)then
begin
a3[i]:=a2[a];
a:=a+1;
end;
end;
writeln(a3);
end.