В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
timur123123
timur123123
13.07.2021 05:26 •  Информатика

Составить программу на языке паскаль : дана матрица а(n, n). составить программу подсчета количества положительных элементов, расположенных выше главной диагонали

Ответ:
20031408
20031408
12.07.2020 13:55
Var n, i, j, ans : integer;
a : array[,] of integer;
begin
    read(n);
    ans := 0;
    SetLength(a, n + 1, n + 1);
    for i := 1 to n do
        for j := 1 to n do
            read(a[i, j]);
    for i := 1 to n do
        for j := i + 1 to n do
            if (a[i, j] > 0) then
                ans := ans + 1;
    writeln(ans);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?