В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
14Dana14
14Dana14
10.01.2023 22:09 •  Информатика

Напишите программу вычисления площади и гипотенузы прямоугольного треугольника ,если известны его катеты.нужно оформить эту программу в виде подпрограммы функция! : )

Ответ:
Kuro111
Kuro111
25.05.2020 14:28

Program n1;
Uses CRT;
Var a,b,c,gip: real;
Function S(x,y: real): real;
begin
s:=x*y/2;
end;
Function G(x,y: real): real;
begin
g:=sqrt(sqr(x)+sqr(y))
end;
begin
Writeln('Vvedite katety');
Readln(a,b);
c:=s(a,b);
gip:=g(a,b);
writeln('Ploshad = ',c:3:2);
writeln('Gipotenuza = ',gip:3:2);
readln
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?