В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
юля2759
юля2759
15.02.2020 19:36 •  Информатика

Плесс. на языке паскаля. напишите программу,которая в последовательности натуральных чисел определяет минимальное,оканчивающееся на 2. программа получает числа. признак окончания ввода 0. количество чисел не превышает 1000. введенные числа не превышают 30000. программа должна вывести одно число - минимальное,оканчивающееся на 2,если таких нет,вывести на экран об этом сообщение.

Ответ:
aidaXdXd
aidaXdXd
05.10.2020 18:16
Var
A,m:integer;

Begin
m:=32767;
Repeat
Read(A);
if (A mod 10 = 2)and(A < m) then m:=A;
Until A=0;

if m mod 2 = 0 then WriteLn(m)
else WriteLn('Чисел, оканчивающихся двойкой нет.')
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?