Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Гогого11
23.01.2023 14:26 •
Информатика
Дан целочисленный одномерный массив. составьте программу, которая искала бы наибольший положительный элемент.
Ответ:
Tinka123
02.10.2020 01:57
Program primer;
const n=100;
var a:array[1..n] of integer;
i,max:integer;
begin
writeln('vvedite massiv');
for i:=1 to n do
readln(' ', a[i]);
max:=a[1];
for i :=1 to n do
if (a[i]>a[1]) and (a[i]>0) then max:=a[i];
writeln('max=',max);
readln;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Сашалажа
26.01.2021 18:49
Составить программу, которая возводит число 5 в степень n входные данные n=2 выходные данные 25...
18alinochka150
26.01.2021 18:49
На какие составляющие делится таблица ascii...
zemkina347
01.09.2020 22:49
В некоторой стране алфавит содержит 64 символа. Найдите информационный вес каждого символа этого алфавита...
dogparrker
14.06.2022 17:18
Рассчитать объем растрового черно-белого изображения размером...
ulyana1512200214
27.12.2020 15:53
Установи порядок алгоритма смены фона фото. Загрузить фотоВыбрать инструмент «Ведро» и выполнить заливку (текстура/передний фон) или инструмент «Градиент»На слое с контекстного...
Dalgat0
04.01.2020 09:55
Кестеде берілген батырмалар қызметін жазыңдар. помагите на казахский...
Klmn2870
08.05.2022 06:34
Как на татарском 1.пришла домой вечером 2. вышли на улицу днём 3.уехали в египет 4. приехали из турции 5. поехали в кино !...
Снежана341
08.05.2022 06:34
Почему нужно желать? почему нужно действовать? дать объяснения...
ajamshid1976p042ct
08.05.2022 06:34
Если рану смазать йодом или зеленкой,что вы поспешите сделать и почему? обоснуйте ответ. вопрос из ....
khubulovaliza
08.05.2022 06:34
1. составить 3 вопроса с -ing и с to-infinitive 2. составить 2 предложений со словами stepson и selfish 3. составить 2 предложения со словами to cheat и lug...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
const n=100;
var a:array[1..n] of integer;
i,max:integer;
begin
writeln('vvedite massiv');
for i:=1 to n do
readln(' ', a[i]);
max:=a[1];
for i :=1 to n do
if (a[i]>a[1]) and (a[i]>0) then max:=a[i];
writeln('max=',max);
readln;
end.