Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
supergirll9
15.11.2022 20:47 •
Информатика
Написать программу нахождения суиммы большего и меньшего из 3 чисел
Ответ:
nataly163
10.07.2020 19:29
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
int selection;
float first, second, result;
cout << "Калькулятор\n";
cout << "1. Сложение\n";
cout << "2. Вычитание\n";
cout << "3. Умножение\n";
cout << "4. Деление\n";
cout << "0. О программе\n\n";
cout << "Введите цифру: ";
cin >> selection;
switch(selection)
{
case 1:
cout << "Введите первое слагаемое: ";
cin >> first;
cout << "Введите второе слагаемое: ";
cin >> second;
result = first + second;
cout << "Результат: " << result << "\n";
break;
case 2:
cout << "Введите уменьшаемое: ";
cin >> first;
cout << "Введите вычитаемое: ";
cin >> second;
result = first - second;
cout << "Результат: " << result << "\n";
break;
case 3:
cout << "Введите первый множитель: ";
cin >> first;
cout << "Введите второй множитель: ";
cin >> second;
result = first * second;
cout << "Результат: " << result << "\n";
break;
case 4:
cout << "Введите делимое: ";
cin >> first;
cout << "Введите делитель: ";
cin >> second;
result = first / second;
cout << "Результат: " << result << "\n";
break;
case 0:
cout << "Программа 'Калькулятор'.\n";
break;
default:
cout << "Необходимо ввести цифру от 0 до 4 в зависимости от Вашего выбора!\n";
}
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
ArtimonТёма22887
06.02.2020 11:13
Укажите отношения для пары текстовый редактор и microsoft word...
shamalava210505
15.07.2021 20:18
1. У лінійному фрагменті алгоритму кожна команда: а)може виконуватися довільну кількість разівб)виконується тільки один разв)може виконуватися один раз, а може й кілька...
Вася11аос
15.07.2021 20:18
Дія, яка розпізнається програмним забезпеченням та опрацьовується програмою за до певних команд:а) випробування б) подія в) подвійна-орієнтація...
newzorowaa2018
24.11.2021 02:13
Даны два числа х и у. Если х и у отрицательны, то каждое значение заменить его абсолютной величиной. Если отрицательно только одно из них, то оба значения увеличить...
Артём19777777
18.12.2022 17:51
Найти сумму тех элементов массива, которые имеют положительные значения(для Паскаль)...
sergeu3522p09njx
06.10.2021 13:53
Написать программу дан массив целых чисел состоящий из 20 элементов. вывести индексы тех элементов значения которых больше заданного числа а...
adilyabaxtigar
01.05.2021 12:26
Подсчитать количество отрицательных элементов, в каждой строке многомерного массива (-35; 60)...
валерия20156
08.11.2020 19:52
Составить предложения с повторяющимися союзами: , , не то, с двойными союзами не только, но как, так два предложения с разными однородных членов. сложносочинённое предложение...
vishnevskayaya
08.11.2020 19:52
От чего не зависит давление жидкости...
ученик445643
08.11.2020 19:52
Какие из этих систем первыми подвергаются воздействию загрязняющих веществ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <cmath>
using namespace std;
int main()
{
int selection;
float first, second, result;
cout << "Калькулятор\n";
cout << "1. Сложение\n";
cout << "2. Вычитание\n";
cout << "3. Умножение\n";
cout << "4. Деление\n";
cout << "0. О программе\n\n";
cout << "Введите цифру: ";
cin >> selection;
switch(selection)
{
case 1:
cout << "Введите первое слагаемое: ";
cin >> first;
cout << "Введите второе слагаемое: ";
cin >> second;
result = first + second;
cout << "Результат: " << result << "\n";
break;
case 2:
cout << "Введите уменьшаемое: ";
cin >> first;
cout << "Введите вычитаемое: ";
cin >> second;
result = first - second;
cout << "Результат: " << result << "\n";
break;
case 3:
cout << "Введите первый множитель: ";
cin >> first;
cout << "Введите второй множитель: ";
cin >> second;
result = first * second;
cout << "Результат: " << result << "\n";
break;
case 4:
cout << "Введите делимое: ";
cin >> first;
cout << "Введите делитель: ";
cin >> second;
result = first / second;
cout << "Результат: " << result << "\n";
break;
case 0:
cout << "Программа 'Калькулятор'.\n";
break;
default:
cout << "Необходимо ввести цифру от 0 до 4 в зависимости от Вашего выбора!\n";
}
return 0;
}