В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
UzZzeR
UzZzeR
04.05.2020 05:49 •  Информатика

Составить программу, которая формирует массив, содержащий 15 случайных целых чисел, принадлежащий промежутку [0; 8], и преобразует элементы массива по следующему правилу: к чётному числу прибавляет 1, а нечётное умножает на 2.

Ответ:
Arinaiv1
Arinaiv1
25.05.2020 11:46

var
  i: integer;
  a: array [1..15] of integer;

 

begin
  write('Исходный массив: ');
  for i:= 1 to 15 do //Формируем и распечатываем массив
  begin
    a[i]:= random(8); 
    write(a[i],' ');
  end;
  writeln; //Перевод на новую строку
  write('Преобразованный массив: ');
  for i:= 1 to 15 do
  begin
    if a[i] mod 2 = 0 then a[i]:= a[i] + 1 {Если элемент массива с индексом i четный, то прибавляем к нему 1, иначе умножаем на 2}
    else a[i]:= a[i] * 2;
    write(a[i], ' ');
  end;
  writeln; {Перевод на новую строку, чтобы при повторном запуске программы сформированный массив печатался на новой строке}
end.

Отметь решение, как лучшее

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?