В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
julyyushchenko
julyyushchenko
20.09.2021 12:27 •  Информатика

Написать программу в паскале! надо! задана последовательность целых чисел,количество которых не превосходит 100.требуется определить за один проход элемент с максимальным значением,а также число его повторений в последовательности.

Ответ:
НикаКотикТян
НикаКотикТян
09.07.2020 15:20
Var
  i,k,max:integer;
  a:array[1..100]of integer;
begin
writeln('Исходная последовательность: ');
for i:=1 to 100 do
  begin
  a[i]:=random(200);
  write(a[i],' ');
  if a[i]>max then
    begin
    max:=a[i];
    k:=1;
    end;
  if a[i]=max then
    k:=k+1;
  end;
writeln;
writeln('Максимальное значение: ',max);
writeln('Число повторений: ',k)
end.
0,0(0 оценок)
Ответ:
Krielov
Krielov
09.07.2020 15:20
Program maxof;
var ar: array [1..100] of integer;
i, j, posl: shortint;
max: integer;
begin
readln(i);
for j:=1 to i do begin
readln(ar[j]);
end;
max:=ar[1];
posl:=1;
for j:=2 to i do begin
if max = ar[j] then inc(posl);
if max < ar[j] then begin posl:=1; max:=ar[j] end; 
end; writeln(max, ' x', posl);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?