В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Dima340
Dima340
20.09.2021 12:27 •  Информатика

заранее ) дана программа: program p1; var a: integer. begin write('введите целое число: '); readln(a); if(a> =100) and (a< 1000)then write(' да') else write(' нет'); end. 1.запишите, что будет выведено на экране в результате выполнения данной в п.1 программы. при=-2, при а=123. 2. внести данную программу изменения таким образом, чтобы программа определяла, удовлетворяет ли данное вещественное число а неравенству -14,5 < a < _ 18, 3. даны целые числа a и b. составьте программу, определяющую, есть ли среди них хотя бы одно, не равное нулю. 4. ввести три целых числа. если ни одно из чисел не является чётным, то вывестина экран их произведение. тема с packal abc.

Ответ:
berezkina04
berezkina04
09.07.2020 15:20
1. Нет, Да
2.
Program p2;
var a:integer.
begin
write('Введите целое число:');
readln(a);
if(a>-14.5) and (a<=18)then write(' Да')
else write(' Нет');
End.
3. 
Program p3;
var a,b:integer.
begin
write('Введите числа:');
readln(a,b);
if(a<>0) or (b<>0)then write(' Есть число, не равное нулю')
else write('Нет чисел, равных 0 ');
End.
4.
Program p4;
var a,b,c:integer.
begin
write('Введите числа:');
readln(a,b,c);
if(a mod 2<>0) and (b mod 2<>0) and (c mod 2<>0)then write(A*B*C);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?