В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Nastyled
Nastyled
05.11.2022 11:10 •  Информатика

Введено число от 1 до 1000 включительно. написать программу, с которой можно найти сумму цифр числа, введенного пользователем. писать на с++

Ответ:
alvd1986
alvd1986
09.07.2020 14:29
#include <iostream>
using namespace std;
int n;
int sum_digits(int n)
{
  int res = 0;
  while (n > 0)
  {
    res += n % 10;
    n /= 10;
  }
  return res;
}
int main()
{
  cin >> n;
  cout << sum_digits(n);
  return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?