Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
muzaka
02.08.2022 04:53 •
Информатика
Напишите программу, в результате выполнения которой первое введённое число уменьшается в три раза, если оно больше, чем третье, а третье становится разностью третьего и второго, если оно больше второго.
Ответ:
ShamilAshimbaj
01.10.2020 23:51
Var
number1, number2, number3 : real;
begin
write('Первое число: ');
readln(number1);
write('Второе число: ');
readln(number2);
write('Третье число: ');
readln(number3);
if (number1 > number3) then number1 := number1 / 3;
if (number3 > number2) then number3 := number3 - number2;
writeln('Вывод');
writeln('Первое число: ', number1);
writeln('Второе число: ', number2);
writeln('Третье число: ', number3);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
мажорчик2
18.08.2021 23:17
Запишите следующее выражение на языке paskal: если a≥(b+c), тогда a=b+c....
знайчушка
14.03.2023 08:23
Задай путём перечисления всех элементов множество A двузначных чисел, кратных 10, и множество B двузначных чисел, кратных 15. Запиши пересечение и объединение этих множеств через запятую...
ElenaBorova
09.02.2020 03:28
Сообщение, записанное с символьного алфавита, содержит 100 символов. Сколько байт занимает сообщение?...
anastasiya258
08.11.2021 04:14
Косновным возможности обработки информации в текстовом процессоре ms word относятся 1 создание презентации 2 создание электронных интерактивных таблиц 3 создание текстовых документов...
elenafilatova11
20.05.2020 21:01
Составьте программу, которая предлагает ввести с клавиатуры две строки, а затем выводит эти строки в алфавитном порядке....
Куликова2006
20.05.2020 21:01
Хотя бы одно из чисел x y z положительно написать на c++...
KrisKvon
16.05.2020 12:04
с заданием Разработайте проект для вычисления значений функции F(x) на отрезке [a,b] с шагом h. F(x)=sinx–cosx a=5, b=6, h=0,1...
aumchik
26.02.2020 13:34
Розвяжіть рівняння (х-3)(2-х)+х2=4...
vorontsovaksus
27.05.2021 13:25
1. Котра година у Києві, якщо у Лондоні 12:00? 2. Котра година у Варшаві, якщо у Києві 10 год? 3. Який буде місцевий час у м. Харкові, якщо у Львові 10-а година? 4. Визначте місцевий...
mitaikooo
09.01.2023 08:04
Определите две территории, лежащие на одном материке в пределах одного государства и ответьте на ряд вопросов о них. I. Эта цветущая (судя по названию) территория большей частью занимает...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
number1, number2, number3 : real;
begin
write('Первое число: ');
readln(number1);
write('Второе число: ');
readln(number2);
write('Третье число: ');
readln(number3);
if (number1 > number3) then number1 := number1 / 3;
if (number3 > number2) then number3 := number3 - number2;
writeln('Вывод');
writeln('Первое число: ', number1);
writeln('Второе число: ', number2);
writeln('Третье число: ', number3);
end.