В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kiratheone
kiratheone
13.08.2021 23:43 •  Информатика

Составить программу которая находит количество натуральных чисел которые не делятся ни на одно из чисел 2,7,11

Ответ:
ilyator
ilyator
08.07.2020 08:52
var
  s, k, err: integer;
  str: string;
begin
  writeln('Введённая пустая строка (без каких-либо символов) считается концом последовательности и, собственно, завершает выполнение программы, как бы говоря ей: "Эй, подруга! Выведи-ка количество чисел, не делящихся ни на два, ни на семь, ни на одиннадцать!"');
  while (true) do
  begin
    readln(str);
    val(str, k, err);
    if (err > 0) then break;
    if ((k mod 2 = 0) and (k mod 7 = 0) and (k mod 11 = 0)) then
      inc(s);
  end;
  writeln(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?