В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
xuimorjovi
xuimorjovi
09.12.2021 06:46 •  Информатика

Структурные операторы в языке pascal: развилка и выбор. 1.даны целые цисла m и n. если числа не равны, то заменить каждое из них одним и тем же числом, равным большему из исходных, а если равны, то заменить числа нулями. 2.составить программу, которая по заданному году и номера месяца m определяет количество дней в этом месяце.

Ответ:
AzatDit
AzatDit
01.10.2020 23:04
Первая прога:
program pr1;
uses crt
var m,n:real;
begin
clrscr;
writeln('insert the numbers');
readln(m, n);
if m <> n then begin
if m > n then begin
n:=m;
end
else begin
m:=n;
writeln(m,n);
end;
end
else begin 
m:=0;
n:=0;
writeln(m,n);
end;
end.

Вторая прога:
program pr2;
ues crt
var y,m,d,k: integer;
begin
clrscr;
writeln('insert the year);
readln(y);
writeln('insert the month');
readln(m);
if m > 12 then begin
writeln('error');
end;
if m mod 2 <> 0  then begin
d:= 31;
end;
if m=2 then begin
d:= 28;
end;
if m mod 2 = 0 then begin
d:=30;
end;
writeln('the number of the days in your month:');
writeln(d);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?