В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vikkisitoff
vikkisitoff
03.10.2021 13:52 •  Информатика

Составить программу вычеслений степени числа а с натуральным показателем n.

Ответ:
arinochkakor1
arinochkakor1
26.05.2020 06:58

Тут используется собственная функция для нахождения степени числа.

 

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

int powerFunction(int, int);

int main()
{
   int number, power;

   cout << "Enter A: ";
   cin >> number;
   cout << "Enter N: ";
   cin >> power;

   cout << number << " to the power of " << power
      << " = " << powerFunction(number, power) << endl;

   return 0;
}

int powerFunction(int n, int p)
{
   int temp = 1;

   for(int i = 0; i < p; i++)
   {
      temp *= n;
   }

   return temp;
}


Составить программу вычеслений степени числа а с натуральным показателем n.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?