Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Mariya1616161
03.01.2023 10:22 •
Информатика
Составить программу в паскале с использованием циклических операторов: найти все натуральные решения уравнения х^2+у^2=м, где м> 0 задает пользователь
Ответ:
khursin03
01.10.2020 23:03
var
x, y, m: integer;
begin
readln(m);
writeln('x':6, 'y':6);
for x := 0 to m do
for y := 0 to m do
if (sqr(x) + sqr(y) = m) then
writeln(x:6, y:6);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Elina558548
10.02.2020 17:28
Алфавит языка программирования содержит строчные и прописные буквы от a до z и знаки арифметических операций . какова мощность этого языка программирования? ...
sasha7666
06.06.2020 09:39
Сколько бит информации будет передано за 9 секунд по линии связи со скоростью 300 бит в секунду?...
SQQQUAD
17.04.2021 11:36
книга содержит 32 страницы на каждой странице 64 строки в каждой строке 128 символов. рассчитайте объём информации содержащийся книге в битах ...
назар163
19.02.2022 06:09
Создать информационную модель одежды,например : платья заранее...
NeZnaiYProsto
14.04.2022 10:43
Сколько бит передается по линии связи , если файл размером 15 байт был передан за 5 секунд?...
Vera4441
02.08.2022 19:47
Кто автор слов: «в интернете себя нужно вести так, как будто вы находитесь в каком-то опасном месте»? мой ответ...
VasG12
22.05.2022 08:59
Сколько времени потребуется для ввода в память компьютера текста на 38 страницах с сканера и программы ABBYY FineReader, если известно, что на сканирование одной страницы...
ЗиА11
07.12.2020 01:19
Расул он создал проект таблица умножения определите соответствует ли скрипты указанным спрайтом поставьте отметки для каждого спрайт используя да или нет скрипт отметка...
егор22813371111
10.10.2021 04:30
Нужно было сделать сайт и изменить цвет текста. и вот я не понимаю как. скажите и желательно поподробней....
Dasha555559
06.03.2021 09:50
Склавиатуры вводится целое число а. если оно двузначное и отрицательное, то вывести на экран слово yes, а в противном случае - вывести на экран слово no...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
x, y, m: integer;
begin
readln(m);
writeln('x':6, 'y':6);
for x := 0 to m do
for y := 0 to m do
if (sqr(x) + sqr(y) = m) then
writeln(x:6, y:6);
end.