Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Андре127
02.12.2022 05:34 •
Информатика
Спрограммой: дана сторона равностороннего треугольника. найти площадь этого треугольника, его высоту, радиусы вписанной и описанной окружностей. в программе microsoft visual studio c#
Ответ:
Ангелина545454
08.07.2020 06:51
[STAThread]
static void Main()
{
double a = double.Parse(Console.ReadLine());
double h, r, R, S;
h = Math.Sqrt(3) / 2 * a;
S = 0.5 * a * h;
r = (2 * S) / (3 * a);
R = Math.Pow(a, 3) / (4 * S);
Console.WriteLine("h = {0}", h);
Console.WriteLine("S = {0}", S);
Console.WriteLine("r = {0}", r);
Console.WriteLine("R = {0}", R);
Console.ReadKey(false);
}
0,0
(0 оценок)
Популярные вопросы: Информатика
kenzhe1
19.12.2022 10:15
Написать программу, которая выводит на экран сообщение (да или нет), равна ли сумма первых двух цифр заданного трехзначного числа последней цифре этого числа. (например:...
0Человек0
24.08.2022 04:33
Информатика 8 класс. Задание во вложении...
Маруська246
08.05.2023 06:01
1) Какие геометрические фигуры ты выбрал при создании нового орнамента и почему?2) Какой предмет домашнего обихода ты можешь использавать для нанесения своего орнамента?...
Hist18
17.12.2021 21:11
4. исполнитель чертёжник перемещается на координатной плоскости, оставляя след в виде линии. чертёжник может выполнять команду сместиться на (a,b) (где a, b - целые...
limi10
21.12.2022 02:49
Решение необходимо как кислород ,паскаль ввести квадратную матрицу порядка n. вычислить произведение элементов, расположенных на главной диагонали. сформировать...
MASTER2008
21.12.2022 02:49
Решение необходимо как кислород ,паскаль дан одномерный целочисленный массив размерностью n. сформировать новый массив из элементов исходного, расположенных до...
Ctatuetca
21.12.2022 02:49
Даны длины двух катетов a и b прямоугольного треугольника. определить периметр этого треугольника p....
spetsialist
09.09.2022 07:36
5. найти наименьшее натуральное число x, удовлетворяющее условию x^{4}-x^{3}-x=10 , или вывести сообщение, что такого числа нет. 6. ввести одномерный массив из...
эаэаэа
09.09.2022 07:36
1. найти площадь равнобокой трапеции с основаниями a и b и углом α при большем основании. 2. ввести три вещественных числа. вывести значение того из них, у которого...
SkyForce144
09.09.2022 07:36
7. ввести вещественную матрицу размером m*n. вывести индексы тех строк, в которых есть хотя бы одно значение, дробная часть которого меньше 0.55, или сообщение...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
static void Main()
{
double a = double.Parse(Console.ReadLine());
double h, r, R, S;
h = Math.Sqrt(3) / 2 * a;
S = 0.5 * a * h;
r = (2 * S) / (3 * a);
R = Math.Pow(a, 3) / (4 * S);
Console.WriteLine("h = {0}", h);
Console.WriteLine("S = {0}", S);
Console.WriteLine("r = {0}", r);
Console.WriteLine("R = {0}", R);
Console.ReadKey(false);
}