Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
ainexl
19.10.2021 17:45 •
Информатика
Написать программу на создать файл а4, состоящий из 28 целых чисел. найти среднее арифметическое всех чисел.
Ответ:
axeltrofimsky
01.10.2020 22:48
Program abc;
var f: text; { Если не будет работать, то написать вместо "text" "file of longint" или еще что-нибудь другое.}
x, y: longint;
i: byte;
begin
y := 0;
assign(f, 'a4');
reset(f);
for i := 1 to 28 do
begin
read(f, x);
y := y + x;
end;
writeln(y / 28);
close(f);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
111ВсЕзНаЙкА111
27.02.2023 21:23
Решить (vba) 1. написать программу вычисления стоимости поездки на автомобиле на дачу (туда и обратно). исходными данными являются: расстояние до дачи (в километрах); количество...
yuliadruzhko
14.06.2021 19:08
два вопроса за один день это 5 класс ...
30kotenok04
03.10.2021 15:53
Назови имя объекта на котором сейчас направлена твое внимание составь характеристику этого объекта. назови имя, перечисли его свойства....
AmoskovaAlenka
20.04.2021 13:09
Из двух простых предложений составьте бессоюзные сложные. расставьте знаки препинания, схемой 1) пары весело кружились в танце. им игриво подмигивали свечи. 2)отовсюду доносились...
ОСА717
20.04.2021 13:09
Решите уравнение 2x+8(9-x)=36 объясните желательно)...
tititititititi
20.04.2021 13:09
Решить . из 1 т молока получается 83 кг сыра или 45 кг масла. на сколько килограммов больше сыра, чем масла, получится из 20 т молока? + краткую запись....
blackytwhite
20.04.2021 13:09
Через хорду основания цилиндра,высота которого равна 12,а радиус основания-8,проведено сечение,параллельное оси цилиндра.угол между радиусами,проведенными в концы данной хорды,равен...
100profan
20.04.2021 13:09
6дм 8мм = 68см надо сравнить правильно или нет...
YuKruglova1
20.04.2021 13:09
Как решить уравнения: 12x - x - 55 = 0 8x - 5x - 3 = 6 2 + 6a + 4a = 92...
dminaeva
20.04.2021 13:09
Выпишите в столбике 1)прилагательные которые пишутся через дефис2)прилагательные которые пишутся слитно северо(западный)научно(технический)жёлто(красный)беспроцентно(выигрышный)высоко(образованный)бело(снежный)красно(речивый)лимонно(жёлтый)научно(фантастический)легко(крылый)подъёмно(транспортный)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var f: text; { Если не будет работать, то написать вместо "text" "file of longint" или еще что-нибудь другое.}
x, y: longint;
i: byte;
begin
y := 0;
assign(f, 'a4');
reset(f);
for i := 1 to 28 do
begin
read(f, x);
y := y + x;
end;
writeln(y / 28);
close(f);
end.